Freshop - Fiserv Gateway Issue – Incident details

All systems operational

Fiserv Gateway Issue

Resolved
Major outage
Started 5 days agoLasted about 6 hours

Affected

Amazon Web Services

Operational from 12:45 PM to 3:32 PM, Partial outage from 3:32 PM to 7:11 PM

Third Party Integrations

Operational from 12:45 PM to 3:32 PM, Partial outage from 3:32 PM to 7:11 PM

Google Cloud Platform

Operational from 12:45 PM to 3:32 PM, Partial outage from 3:32 PM to 7:11 PM

Third Party Integrations

Operational from 12:45 PM to 3:32 PM, Partial outage from 3:32 PM to 7:11 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    At approximately 8:45 AM EST on June 19, 2025, a Fiserv JS payment endpoint stopped responding. We have escalated the issue to Fiserv and will provide updates as more information becomes available. In the meantime, Freshop engineering identified an alternative, functional Fiserv JS payment endpoint and redirected affected retailers to this new endpoint.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    At approximately 8:45 AM EST on June 19, 2025, a Fiserv JS payment endpoint stopped responding. We have escalated the issue to Fiserv and will provide updates as more information becomes available. In the meantime, Freshop engineering identified an alternative, functional Fiserv JS payment endpoint and redirected affected retailers to this new endpoint.