Thursday 1st July 2021

Inmar Inmar Reach Digital Coupons display issue

[INVESTIGATING 2021-07-01 9:30 EST] We identified a display issue on Freshop's end with the Inmar Reach digital coupons and have applied a fix.

[RESOLVED 2021-07-01 11:30 EST] We have identified the issue, a bug, and resolved it.