Tuesday 17th August 2021

High API Latency

[FIXED 2021-08-17 23:10 EST] Due to excessive resource consumption, one of our database servers was experiencing high latency. The API latency is back to normal levels. We will continue to monitor performance.

[INVESTIGATING 2021-08-17 22:50 EST] We are experiencing higher than normal API latency and are investigating.