Thursday 30th September 2021

Intermittent SSL Certificate Issue

[RESOLVED 2021-09-30 11:45 EST] This can be fixed either by clearing the browser cache or waiting for the browser to remove the expired cached certificate and request for a new one as per the regular process.

[IDENTIFIED 2021-09-30 11:00 EST] We have identified that some web browsers are caching an older expired certificate, which is causing this issue

[INVESTIGATING 2021-09-30 10:05 EST] We are seeing that some users are having issues involving ssl certificate authentication when accessing Freshop sites