Thursday 30th September 2021

SSL Certificate issue affecting multiple service providers

[RESOLVED 2021-09-30 14:40 EST] Lets Encrypt provides SSL certification to a number of Cloud service Providers. Lets Encrypt refreshed their certificates today. Freshop's servers were not getting these certificates automatically refreshed and we had to manually refresh the certificates. This issue has now been resolved.

[INVESTIGATING 2021-09-30 13:05 EST] 3rd party service providers (ex. Digital Coupon) who have an SSL certificate issued by Lets Encrypt were impacted.