Thursday 26th March 2020

Freshop Admin for Web High API Latency / Slowness

[RESOLVED] - We've successfully added capacity and are seeing load times going back to normal.

[UPDATE] - We've increased the capacity of some servers and monitoring the stability.

We are experiencing higher than normal API latency due to extremely high traffic. We are rapidly adding more capacity.