Friday 3rd April 2020

Freshop Admin for Web Freshop Admin performance issue

[INVESTIGATING] Freshop Admin is experiencing performance issues. We're investigating.

[RESOLVED] We've identified the root cause in one of our database segments, which resulted in errors in updating order status. We fixed the issue and operations are back to normal.