Sunday 15th March 2020

Freshop Admin for Web API Latency issue

[UPDATE] - The issue has been resolved with the database segment and normal operations has resumed.

Investigating issue with one of the database segments.