Wednesday 26th May 2021

DO-11 One of the Web servers experiencing issues

[INVESTIGATING 2021-05-26 14:01 EST] One of the web servers is experiencing issues, resulting in performance impact or total outage of some sites. We're working with our Hosting Service Provider to resolve this issue.

[RESOLVED][2021-05-26 14:32 EDT] Hosting service has completed their fix. "[server] services were restarted"