Monday 14th June 2021

Payeezy - Integrated Payeezy Payments are not going through due to network error

[INVESTIGATING 2021-06-14 9:00 EST] Some stores using Payeezy as a payment provider are facing issues due to network errors. We're investigating and working with FristData on this issue.

[IDENTIFIED 2021-06-14 10:05 EST] We have isolated issue to be a read timeout error on FirstData side. We're working with Payeezy Gateway Support team to resolve the issue.

[RESOLVED 2021-06-14 10:31 EST] FirstData/Payeezy had resolve the network issue on their side and we see successful payment transactions going through Freshop again. We will continue to monitor for successful transactions.